phalcon devtools开发工具安装及生成多模块web项目的攻略终极版

Posted by

之前文武双全写过一篇phalcon devtools开发工具的教程,后来实际操作的时候发现老版本的devtools存在一个严重关于多模块的bug。文武双全自己动手解决了这个bug,还提交Pull Request给phalcon的作者。幸运的是,我提交的代码被乌克兰大神采用了。phalcon devtools的最新的代码是3.0.x分支,这个版本是多模块bug修复过的版本。只推荐下载这个版本,并且使用他生成多模块的项目。

不要使用3.0.3及以下版本的phalcon devtools生成项目

使用老版本的phalcon devtools 在命令行下生成的多module有一个严重的bug,多模块无法正常工作。这个bug,已经在3.0.x分支被我修复啦,哈哈。希望尽快出3.0.4版本,让大家可以爽翻phalcon。

推荐使用git安装devtools,然后执行3.0.4以后版本的phalcon-devtools的安装程序

通过git下载最新版本的phalcondevtools
通过git下载最新版本的phalcondevtools

使用git下载3.0.4以上版本的devtools的源代码后,然后执行安装程序。不过,我没试过。。。

安装完以后,就可以按照这篇文章的方法,去生成多模块的web项目啦。

phalcon devtools快速开发工具新手入门——使用phalcon devtools快速生成多模块web项目的方法

 

2 comments

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.